下载安装编译好的nodejs (根据自己的需要选择版本)

[root@localhost ~]# wget https://nodejs.org/dist/latest-v4.x/node-v4.8.0-linux-x64.tar.gz
[root@localhost ~]# tar -xzvf node-v4.8.0-linux-x64.tar.gz
[root@localhost ~]# ln -s /root/node-v4.8.0-linux-x64/bin/node /usr/bin/node
[root@localhost ~]# ln -s /root/node-v4.8.0-linux-x64/bin/npm /usr/bin/npm
[root@localhost ~]# node -v && npm -v
v4.8.0
2.15.11

更换 nodejs npm 版本可以通过安装 n 模块进行相应操作

[root@localhost workspace]# npm install -g n
/root/node-v4.8.0-linux-x64/bin/n -> /root/node-v4.8.0-linux-x64/lib/node_modules/n/bin/n

列出目前可用的nodejs版本
[root@localhost workspace]# n ls
0.0.1
0.0.2
0.0.3
0.0.4

7.4.0
7.5.0
ο 7.6.0

安装稳定版本
n stable
安装指定版本
n 6.5.0

安装最新npm至全局
npm update npm -g

 

npm install <name>安装nodejs的依赖包

例如npm install express 就会默认安装express的最新版本,也可以通过在后面加版本号的方式安装指定版本,如npm install express@3.0.6

npm install <name> -g  将包安装到全局环境中

但是代码中,直接通过require()的方式是没有办法调用全局安装的包的。全局的安装是供命令行使用的,就好像全局安装了vmarket后,就可以在命令行中直接运行vm命令

npm install <name> –save  安装的同时,将信息写入package.json中

项目路径中如果有package.json文件时,直接使用npm install方法就可以根据dependencies配置安装所有的依赖包

这样代码提交到github时,就不用提交node_modules这个文件夹了。

npm init  会引导你创建一个package.json文件,包括名称、版本、作者这些信息等

npm remove <name>移除

npm update <name>更新

npm ls 列出当前安装的了所有包

npm root 查看当前包的安装路径

npm root -g  查看全局的包的安装路径

npm help  帮助,如果要单独查看install命令的帮助,可以使用的npm help install